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Introduction 
SharePoint 2010 is the core server component of the Microsoft Office System.  The Office System 

includes many of Microsoft’s products such as SharePoint Server, SharePoint Foundation, Word, Excel, 

PowerPoint, Lync (previously Live Communications Server), and SQL server.  SharePoint 2010 is a 

business collaboration platform used to set up web sites across which information is shared.  SharePoint 

2010 allows people to work together more efficiently, access information faster, create solutions to 

respond to business needs and increase productivity. 

Libraries 
Document libraries are collections of files that you can share with team members. For example, you can 

create a library of common documents for a project, and team members can use their Web browsers to 

find the files, read them, and make comments. Users with Microsoft Office can check out and edit the 

files as if they resided on a local or network drive.  SharePoint offers different types of libraries.  This 

training covers Document libraries.   

Documents Tab Library Tools  
The tool bar across the top of a tab area is called a ‘ribbon’. It contains the tools available within that tab 

area. The tools shown on a ribbon change based on the tab you are viewing. Below are options available 

on the Documents tab ribbon.   

 

Upload Documents 
Users can upload a single document or multiple documents at one time. 

To Upload a Single Document 

1. Click Add Document    
2. Click Browse;  select a file  
3. Click OK 

Note:  Users can change their destination folder by clicking ‘Choose Folder’. 
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To Upload Multiple Documents 

Drag and Drop Option:   

SharePoint allows users to drag and drop multiple files into the Upload Multiple Documents window.   

1. Click Add Document then Upload Multiple Files  >  
2. Drag and drop selected files  

 
 

3. Click OK 

Browse Option:  

SharePoint allows users to browse and select multiple files to include in the Upload Multiple Documents 

window.   

1. Click Add Document then Upload Multiple Files. >  
2. Click Browse. The file selection dialog box will open. 

  
3. Click OK 

Create a New Document 
When a user creates a document within a library, it is automatically stored in the library.   

1. Go to a Library 

2. Click New Document >  New Document 
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3. ‘Open’ message displays. 

  

4. Click OK 
5. Enter a file name and click Save 

 
 

Check Out & Check In Documents 
The ‘Check Out’ option allows a user to check out a document and make changes.  Other users cannot 

edit the file until the user checks the file in again, nor can they see changes made during checkout until 

the file is checked in.  If a user opens a file while it is checked out, the user will see the old version of the 

file until the user editing the file checks in the document.  SharePoint allows users to check out more 

than one file at a time.  Full Control users can configure a library so users are required to check out the 

document.   

Note:  Only Full Control users can ‘Check In’ other users’ documents.       

Check Out Document 

Contribute users can check out a document for editing. 

1. Put a check in the box  next to the file or files to check out, as shown here:  

2. Click Check Out    
3. Confirmation message (shown below) displays. 
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4. Click OK 

5. The checked out symbol  displays next to the file    
6. Click on the file to open it. After making changes, click Save and close the file. 

7. Click Check In   
8. The ‘Check In’ window opens. 

 
Note: Comments are valuable to other users after a document is checked in.  All comments 

entered at check in are stored in the properties of the document.  This allows users to view prior 

versions and their comments. When checking in a document it is helpful for yourself and others 

if you briefly document the change you made by putting a note in Comments. Example: If you 

add a section, simply add “Added section [section name]”. If you delete a section address it the 

same way. 

9. Click OK 

Discard Check Out 

The Discard Check Out option allows Contribute users to check in a document without saving any of 

the changes made during the checked out period.      

1. Click Discard Check Out   
2. Confirmation message displays.  

 

3. Click OK 
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Edit the Document  

1. Go to the document library that contains the file 

2. Check the box to the left of the file name  
3. The ‘Documents’ menu ribbon displays  

 

4. Click the Edit Document icon:   
5. Open Document Message displays.  

 
6. Click OK 
7. Make changes to document 
8. Click Save 
9. Close document by clicking the X or selecting File > Close from the top menu 

 

Reminder:  If the document is Checked Out, the user has to Check In the document for other users 

to see the changes. 

Delete a Document 
Users can delete one or more documents at a time.  When a document is deleted it is stored in the 

user’s Recycle Bin until deleted from the Recycle Bin and up until this point it can be restored from the 

Recycle Bin if needed.  (See ‘Restore from Recycle Bin’ below.) 

1. Check the box next to the file(s) 

2. In the ‘Documents’ menu ribbon, click Delete Document   
3. A confirmation message displays.   

 
 

 

 

 

4. Click OK 
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View Properties 

The View Properties dialog box shows the Name, Title, when the document was created, when it was 

last modified, and by whom.   

 

E-mail a Link instead of a Document 

SharePoint lets users email a link to a document to other SharePoint users instead of attaching the 

actual document to an email.  When users email documents back and forth it can cause confusion 

identifying the most current document and it inflates the size of the user’s mailbox.  When the recipient 

clicks the email link, the latest version of the document opens. Using a link instead of passing a 

document also ensures that only one person can edit the document at a time, eliminating the need to 

merge multiple edits during reviews. 

To Email a Document Link   

1. Go to the library where the document is stored 
2. Mouse over the file then check the box to the left of the file name 

 

 Users cannot check more than one file at a time.   

3. Click Library Tools >Documents tab, E-mail a Link   
4. Enter message and send email   

 

Note:  Do not send links to external users who do not have access to SharePoint.  Continue to 

send attachments to external users. 
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Send Multiple Links in Email 

Follow the steps below to send multiple links in one email message. 

1. Create a New Email  
2. Follow steps 2 – 4 for ‘Email a Link’ 
3. Copy and paste each link into the main email message 
4. Send email 

 

Restore from Recycle Bin 
Users with Contribute and above permissions have a recycle bin.  Each site that the user has access to 

contains a unique recycle bin.  To restore a deleted file, the user must be at the site where s/he deleted 

the file and look in that site’s Recycle Bin to verify the file is there.   

Scenario:  A user has Contribute permissions on the SharePoint site.  S/he deletes a file on the Human 

Resources site, but later on decides to restore it.  If the user looks in the recycle bin on the main 

SharePoint site, s/he will not find the file.  The user can restore the file from the recycle bin on the 

Human Resources site.  SharePoint restores the file back to its original location.   

1. Go to site where the file was deleted 
2. Click Recycle Bin (bottom of Quick Launch section) 
3. Put a check next to the file(s), read the ‘Original Location’ information (location for document 

restore) 
4. Click Restore Selection 

 

5. A confirmation message displays.   

 
6. Click OK 
7. Users can view the restored file by navigating to the location where it was originally stored. 
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Add a Folder 
Users with Contribute and above permissions can organize files in a library by adding folders.  

SharePoint folders are similar to the hierarchy of local and shared network drives.   

1. Go to the Library (click within Library to make ribbon display) 

2. Click Documents tab then New Folder   
3. Enter a name: click Save 

 

4. A folder icon displays next to the folder name  
 

Best Practice:  When creating the folder, give the folder an abbreviated name without spaces.  After the 

folder is created, go into the Library permissions and rename the folder to include spaces.  SharePoint 

has restrictions on character lengths for folder names in the URL.  Example:  Create a folder called New 

Folder and rename it an appropriate name.     

Rename a Folder 
There are two ways to rename a folder:  use the ribbon or the drop-down menu.   

Rename Using the Ribbon 

1. Go to library that contains the folder 

2. Put a check next to folder  

3. Click the Edit Properties icon  to open the edit properties dialog box:   

 

4. Type a new name in the Name field in dialog box 
5. Click Save 
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Display the Drop-down Arrow Menu 

1. Mouse over the folder and click the down-arrow 
2. Select Edit Properties 

 

 

3. Enter the new name and click Save 
 

Delete a Folder 
Folders can be deleted using the Ribbon or the drop-down menu.   

Ribbon 

1. Go to library that contains the folder 

2. Put a check next to folder  

3. The ‘Documents’ menu ribbon displays  

4. Select Delete Document  
5. A confirmation message displays. 

 

6. Click OK 
 

Drop-down menu 

1. Go to library that contains the folder and hover on folder 
2. Click down-arrow > Delete 
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3. Confirmation message displays.  
4. Click OK 

 

Set Alerts (Alert Me)  

SharePoint provides the option to receive email notifications (alerts) when content is added, modified, 
or deleted on the site.  Alerts can be set for lists, files, or folders.  Full Control users can set alerts for 
themselves and create alerts for other site users.   

Set Alerts 

1. Go to the library where the document is stored 
2. Hover on file and check the box that displays to the left of the file name 

 

3. Click Library Tools >Documents tab 
4. Click Alert Me  
5. Select Set alert on this document 

 

6. Alert Title:  Default is shown 

 User can enter a different title 
7. Delivery Method:  Default is shown 
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8. Send Alerts for These Changes:  Anything changes is default 

 Additional options for Contribute and above users: 
 Someone else changes a document 
 Someone else changes a document created by me 
 Someone else changes a document last modified by me 

9. When to Send Alerts:  Send notification immediately is default 

 Immediate Notification is the default setting for Alerts.  Users will receive an email 
within 1 – 5 minutes of the change.  Keep in mind, if someone is constantly making 
changes and saving throughout the day, users will receive an email each time the file is 
saved.   

 Daily Summary allows users to select a specific time to receive email notifications.  Users 
will receive one email that contains a summary of the changes. 

 Weekly Summary allows users to select a specific day and time of the week to receive 
notifications. 

10. Click OK  
11. The user receives an email with the subject “You have successfully created an alert for ….” 

 

Modify/Delete an Alert 

Follow these steps to change the alert settings or delete the alert. 
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Modify an Alert 

1. Click the user menu arrow (top right corner of page) 
2. Click My Settings 

 
 

3. Click My Alerts 

 

4. Modify an existing alert:  Click the alert  

 
 

5. Make changes 
6. Click OK 

 
 

Delete an Alert 

1. Follow Modify an Alert steps 1 – 3 
2. Check the box, click Delete Selected Alerts 
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3. Confirmation messagedisplays.   

 

4. Click OK 

Download a Copy 

Users can download the latest ‘version’ of a document or form.   

1. Go to the library where the file is stored 
2. Select the file to be downloaded by checking the box next to the file name. 

3. Check box next to document   

4. On the Library Tools – Documents tab, click Download a Copy   
5. An option message displays at the bottom of screen.  

 

6. Click  the Save arrow  and select either Save or Save as 

Note:   The message may vary, depending upon the type of browser and the settings.  

Best Practice: Always go to the SharePoint site to pull the latest version to ensure it has the most 

current information. 

Library Tools - Library Tab 
Below are options available on the Library tab ribbon.  

 

Standard View or Datasheet View 

Standard View is the default view for all libraries.  The Datasheet View allows users to copy data and 

display it in a spreadsheet view.   

Toggling Between Standard and Datasheet View 

1. Go to list location 
2. Click Library Tools >Library tab > Datasheet View  
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3. To return back to standard view click Standard View  

Creating Views 

Before you start creating a view, you will want to do a little planning. Let's say, for example, that you just 
want a standard view. For a Standard View you should consider: 
 What do you want to name your view? 
 Do you want it to be a personal view (only you can see it) or a public view (everybody can see it, 

and you need to have certain permissions to be able to do this)? 
 What columns do you want to see on the view? One common mistake is to pick everything, but 

typically users only need to look at a few, so think carefully about what you need to see. Don't 
hesitate to come back to edit the view after you start using it when you realize that there are 
columns that you never really look at.  

 Make sure your view includes the minimal number of lookup columns (fields of type Lookup, 
Person/Group, or Workflow Status), because each lookup you add to your view impacts 
performance 

 Do you want to group your view by a certain column? For example, if you were to create a view on 
a list of all your tasks, you may want to group them by due date.  

 Do you need to sort the view in a particular way? If so, how, and is it necessary? If the list is large, 
this may impact performance.  

 How many items do you want your view to return, and should it page them or do you just want to 
see the top X#? If you don't think you'll ever go to that 2nd or 3rd page, then it's best to limit the 
returned set as much as possible.  

 Do I need to see the items inside folders, or do I just want everything bubbled up into my view?  
 Will I need to use this view on the go? If so, you want to make sure you think about the Mobile 

settings for whether to enable the view for mobile access, and how many items it should display in 
a list view web part.  
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1. Click the "Create View" button 
2. Now you may select the type of view you prefer. You may copy an existing view that you just 

want to tweak without changing the original view, or create one of the following formats: 
 Standard View 
 Calendar View 
 Access View 
 Datasheet View 
 Gantt View 
 Custom View in SharePoint Designer 

  
1. Create a Standard View and supply a name in the Name field 
2. Select ‘Make this the default view’ if you are asked to do so 
2. Select Public or Private View.  
3. Select the columns you would like to display in your view 
4. Determine if you would like to sort the items in the view 
5. Expand the remainder columns for further adjustments to your view 
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Connect to Outlook 

Users can synchronize lists (library, calendar, contact list, task list) with Microsoft Outlook 2010.  

Connecting lists to Outlook can help users work more efficiently, especially if users work offline or do 

not have convenient access to SharePoint sites all the time. 

1. Go to list location 
2. Click Library Tools – Library tab, click Connect to Outlook   
3. Confirmation message display.  

 

4. Click Allow 
5. Confirmation message displays. 

 Click Advanced for more details 

 Click Yes to proceed without,  or after, exploring Advanced 

 

6. A folder is created in Outlook 

 
 

7. Documents and additional information are shown in the Outlook window 

 

Delete the Outlook Folder 

1. Go to Outlook and right-click the folder 

2. From the right-click menu, select Delete Folder  
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3. Outlook confirmation message displays.   

 

4. Click Yes 

Open with Explorer 

Users can open the library as a standard Windows Explorer folder.  Read users can use the Explorer view 

to download multiple files from SharePoint to a computer or network drive.  Contribute and Full Control 

users can drag and drop files into the SharePoint library, create folders, move or copy files, and delete 

multiple files.   

1. Go to library and click Library Tools >Library tab 
2. Select Open with Explorer  
3. An Explorer window opens displaying content in Explorer view 
4. Note:  Be patient, it may take 1 – 2 minutes to open with Explorer. 
5. Click X to close window 

 

Drop-Down Arrow 

There is more than one way to complete an action in SharePoint.  Instead of using the ribbon, users can 

use the down arrow to complete actions. 

1. Hover next to file 
2. Click arrow, select an action 

Note:  The example below displays options for Read users.  Contribute and Full Control users 
have more options available. 
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Practice Activities 
Before continuing the training, practice what was covered in the Libraries section by completing the 

practice activities.   

Practice:  Create a new document and upload files  

1. Create a new document in your library called ‘Test’  
2. Upload multiple documents (2 or more) to your library 

 

Practice Notes: 

 

 

 

Practice:  Check Out a document and edit the file 

Within your library, check out a document and Edit in the browser. 

Practice Notes: 

 

 

 

Practice:  Delete and Restore a Document 

1. Go to your library and delete a document 
2. Restore the document back to the library 

 

Practice Notes: 

 

 

 

Practice:  Add a Folder 

Go to the library you created and add a folder called ‘Test’. 

Practice Notes: 

 

 



              
 

Page 23 of 37 
 

 Contribute User Training 
 

Practice:  Rename the Folder 

Change the name of the folder added to the Library. 

Practice Notes: 

 

 

 

Practice:  Delete a folder 

Delete the folder added to the library. 

Practice Notes: 
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Picture Libraries 
Picture libraries are similar to document libraries, but designed to show thumbnails and other views.  

Reed-Custer has 2 picture libraries on the District and School sites.  On the District site has the following 

picture libraries: 

District Pictures 
District_Top_Pictures:  This library is for pictures at the top of the district page on the random picture 

carousel only. 

District_Site_Pictures:  This library is for pictures on the district site excluding the top random picture 

carousel.  These pictures can be added to content as needed. 

School Pictures 
High_School_Top_Pictures:  This library is for pictures at the top of the High School page on the random 

picture carousel only. 

High_School_Site_Pictures:  This library is for pictures on the High School site excluding the top random 

picture carousel.  These pictures can be added to content as needed. 

Middle_School_Top_Pictures:  This library is for pictures at the top of the Middle School page on the 

random picture carousel only. 

Middle_School_Site_Pictures:  This library is for pictures on the Middle School site excluding the top 

random picture carousel.  These pictures can be added to content as needed. 

Intermediate_School_Top_Pictures:  This library is for pictures at the top of the Intermediate School 

page on the random picture carousel only. 

Intermediate_School_Site_Pictures:  This library is for pictures on the Intermediate School site 

excluding the top random picture carousel.  These pictures can be added to content as needed. 

Primary_School_Top_Pictures:  This library is for pictures at the top of the Primary School page on the 

random picture carousel only. 

Primary_School_Site_Pictures:  This library is for pictures on the Primary School site excluding the top 

random picture carousel.  These pictures can be added to content as needed. 

Upload a Picture 
1. Go to picture library, click on the Documents tab in the ribbon to open the tools ribbon for 

documents. 

 
2. Click Upload Document 
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 Browse for file, click OK 

 

 

 

3. Enter additional information (optional), click Save 
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Pictures will show thumbnail images for quick viewing of the library. 
 

 

Edit a Picture 
Contribute users can edit picture properties stored in SharePoint.   
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1. Go to picture library 
2. Check the box next to picture 

 
3. Click Edit Properties   

 Picture Editor loads 

 Make adjustments changes to the pictures properties  
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4. Click Save and Close 
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Practice Activities 
Before continuing the training, practice what was covered in the Picture Libraries section by completing 

the practice activities.   

 

Practice:  Upload a picture  

Upload two or more pictures into a picture library. 

Practice Notes: 

 

 

Practice:  Edit a Picture 

Select a picture and make changes to it.  Resize it, change the color, or crop it.   

Practice Notes: 
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Important Information 
Most sites have an Important Information area where users can share information.   

Add an Important Information 
1. Go to the site that displays the Important Information 

2. Click on the IMPORTANT INFORMATION header  

3. Click on the Add new Announcement  
4. Title:  Enter a Title (required) 

 
 

5. Body:  When you enter message/announcement 

 Users can attach a file and run spell check 
6. Expires:  Optional 

 An expiration date is when the list item is no longer relevant, which allows views to filter 
out older items to display on the most recent announcement.  

7. Display On School Site:  Checking this box will display the Important Information on all school 
sites and the district site. 

8. OR: Display On District Site:  Checking this box will display the Important Information on the 
District site as well as the current school site. 

9. Click Save 
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Edit an Important Information 
1. Go to the site that displays the Important Information 

2. Click on the IMPORTANT INFORMATION header  
3. Hover on the announcement and click the down-arrow to display the menu.  
4. Select Edit Item (as shown below) 
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5. Make changes to item  

 

Note: Attachments can be added and deleted from the Important Information using the Attach 

File ribbon item or deleted using the Delete Link next to an attachment. 

6. Click Save 

Delete an Important Information 
1. Go to the site that displays the Important Information 

2. Click on the IMPORTANT INFORMATION header  
3. Hover on the announcement and click the down arrow 
4. Select  Delete Item from the menu 
5. Confirmation message Displays:  Click OK 
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Note:  You can restore the Important Information from the recycle bin.  Refer to ‘Restore from Recycle 

Bin’ section.   
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Practice Activities 
Before continuing the training, practice what was covered in the Announcements section by completing 

the practice activities.   

 

Practice:  Add an Announcement 

Add an announcement.  Change the permissions so only two or more people can read the permissions.   

Practice Notes: 

 

 

Practice:  Edit an Announcement 

Add an attachment (document) to the announcement.  Set the expiration date for today’s date.   

Practice Notes: 

 

 

 

Practice:  Delete an Announcement 

Delete the announcement without an expiration date.   

Practice Notes: 
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Upcoming Events 
The SharePoint calendar contains many features, which allow users to add events, connect to Outlook, 

and track meetings, deadlines and milestones.   

Add Upcoming Event  
You can post Events on the calendar. Example:  For a holiday you might want to put a reminder that 

schools are closed.   

1. Go to the site that displays the Upcoming Events 

2. Click on the UPCOMING EVENTS header  
3. Mouse over  a date and click the Add link that displays 
4. New item window displays 
5. Enter information and choose options, click Save 

 

Note:  If the event is all day, put a check in the box for ‘All Day Event’.   

 

Edit an Upcoming Event 
1. Go to the site that displays the Upcoming Events 

2. Click on the UPCOMING EVENTS header  
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3. Click on Event > Edit Event   
4. Make changes 
5. Click Save 

Delete an Event 
1. Go to the site that displays the Upcoming Events 

2. Click on the UPCOMING EVENTS header  
3. Click on the Event (don’t have to open it) 

4. Click Delete Event   
5. Confirmation message displays.   
6. Click OK 

 
Note:  This message means users can restore events from the Recycle Bin.  See the ‘Restore from 

Recycle Bin’ section.   
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Practice Activities 
Practice what was covered in the Calendars section by completing the practice activities.   

 

Practice:  Add a Calendar 

Go to a calendar and add it as a shared calendar to your Outlook (Connect to Outlook). 

Practice Notes: 

 

 

 

Practice:  Add Event to Calendar 

Add an Event to your SharePoint calendar.  Forward the Event to your email address.   

Practice Notes: 

 

 

 

Practice:  Delete an Event 

Delete the Event from the SharePoint calendar.   

Practice Notes: 

 

 


